Warning: fopen(logs/log_ouvindo_opinioes.txt) [function.fopen]: failed to open stream: No such file or directory in /home/storage/6/a1/fc/edudelphipage/public_html/includes/edp_log.php on line 6

Warning: fwrite(): supplied argument is not a valid stream resource in /home/storage/6/a1/fc/edudelphipage/public_html/includes/edp_log.php on line 8

Warning: fclose(): supplied argument is not a valid stream resource in /home/storage/6/a1/fc/edudelphipage/public_html/includes/edp_log.php on line 9
 EduDelphiPage - Ouvindo Opiniões | Qual versão do Delphi utilizar?

Ouvindo Opiniões

Qual versão do Delphi utilizar?

Opinião escrita por Victory Fernandes

Sobre o autor: Colunista da ActiveDelphi e Autor de inúmeros artigos para as Revistas ClubeDelphi e TheClub. Engenheiro Eletricista, Professor do Departamento de Engenharia da UNIFACS - Universidade Salvador. Diretor Tecnico da TKS Software
Site pessoal: www.igara.com.br/victory

Contato: victoryfernandes@yahoo.com.br

O primeiro ponto neste caso é que, a menos que exista um motivo muito forte para fazermos uma migração, em projetos antigos nós sempre mantemos a versão utilizada na compilação! Se um projeto começou em Delphi 7 e atende bem às necessidades do cliente, ele é mantido em Delphi 7 "até que a morte os separe"! Somente no início de novos projetos é que optamos por migração de plataforma, essa é uma norma que adotamos, principalmente para evitar problemas com componentes de terceiros utilizados durante o processo de desenvolvimento etc.

Aqui na empresa utilizamos na grande maioria dos projetos, o Delphi 6 ou 7 e destas versões não tenho nada o que reclamar, super estáveis, bastante completas e funcionais!

Recentemente, adotamos como padrão para os novos projetos o BDS2007, apesar do alto requisito de memória e processamento, o que requer certa atualização nas máquinas de desenvolvimento, não tivemos maiores problemas com a nova plataforma, até resolvermos adequar algumas de nossas soluções Intraweb para operar em PDA e celulares. Para nossa surpresa, simplesmente não funciona! Há diversos posts na internet relatando o problema!

Chegado o BDS2009, atualizamos a plataforma dos nossos aplicativos Intraweb, uma vez que o problema da operação em dispositivos móveis havia sido corrigido... e agora qual o problema?! Estamos tendo sérias dificuldades com a versão Bundled Edition do Rave Reports no que diz respeito a geração de relatórios em formato .PDF em aplicações Intraweb, apresenta access violation, e segundo relatos somente uma atualização online corrige o problema.

Nos dois casos, os problemas citados eram relacionados a ferramentas de terceiros incorporadas à plataforma. Neste ponto creio que deva haver um maior rigor envolvendo tais soluções, pois no final das contas, os prejuízos e insatisfações recaem sobre o Delphi.

Continuo acreditando no Delphi e até hoje sempre tive sucesso nos desenvolvimentos com base nesta plataforma, aconselho e uso sempre que possível a versão mais atual disponível! Mas sempre deixo o meu bom e velho Delphi 6 ou 7 instalados para uso em casos onde há poucos requisitos e não preciso de nada muito elaborado!

Comentários

Nenhum comentário foi feito ainda
 

"Ouvindo" Opiniões (as mais lidas)

Em breve, aguarde!!!

Pharetra Sed Tempus

Morbi sit amet mauris Nam vitae nibh eu sapien dictum pharetra. Vestibulum elementum neque vel lacus. Lorem ipsum dolor sit dolore phasellus pede lorem proin auctor dolor loremmassa phasellus sit. More…

Outras edições da Revista Active Delphi